Help Center

A collection of frequently asked questions
Library
  • How do I backup my BeadTool files and settings?
    To backup your BeadTool related files and settings:
    1. Windows: Click View->Options from the main menu and select the Library tab.
    2. Mac: Click BeadTool4->Preferences from the main menu and select the Library tab.
    3. Click the Backup Now button and save the database anywhere you like.
    To restore a previous backup:
    1. Windows: Click View->Options from the main menu and select the Library tab.
    2. Mac: Click BeadTool4->Preferences from the main menu and select the Library tab.
    3. Click the Restore button and open your backup file.
  • How do I transfer my entire BeadTool Library to another computer?

    On computer 1:

    1. Windows: Click View->Options from the main menu and select the Library tab.
    2. Mac: Click BeadTool4->Preferences from the main menu and select the Library tab.
    3. Click the Backup Now button and save the database to your Desktop.
    4. Save the file you put on your Desktop to a Flash drive or email it to yourself.

    On computer 2:

    1. If you haven't downloaded and installed BeadTool on Computer 2, do that now. Always ensure that you have the latest version by downloading here.
    2. Windows: Click View->Options from the main menu and select the Library tab.
    3. Mac: Click BeadTool4->Preferences from the main menu and select the Library tab.
    4. Click the Restore button and select the backup file you created previously.
  • When I save my patterns and palettes, where do the files go?

    BeadTool saves all patterns, palettes, layouts and settings to a single database file. This makes backup a simple task and frees you from having to figure out where everything is.

    While it is not recommended, it is possible to disable the entire Library functionality and go back to storing individual files on your computer.

  • How do I save individual files from my Library to my computer?

    If you need to take a pattern, palette or layout from your Library and save it as an actual file onto your computer or flash drive, follow these steps:

    1. Run BeadTool and click the Browse button to open your Library
    2. Navigate to the file you want to take from your Library and right click on it
    3. Select the Save To... option and save it anywhere you wish

    You can also do these steps with your Library folders. For instance, if you wanted to save your entire "My Patterns" folder to your desktop, you'd right click on that folder instead of just 1 individual pattern file.

    To get them back (or transfer from another computer):

    1. Run BeadTool and click File->Import->Multiple files
    2. Navigate to the folder you keep your patterns.
    3. Once BeadTool shows you all the files that can be imported, click the Import button.
  • How do I open BeadTool 3 files in BeadTool 4?

    Since BeadTool 4 uses a single-file database to store all patterns, palettes and layouts you'll need to take those BeadTool 3 files and import them into your Library database. The process is fairly simple:

    1. Run BeadTool 4 and click File->Import->Multiple files on BeadTool's main menu
    2. Navigate to the folder where you keep your BeadTool 3 files
    3. Click the Import button
    4. When you're shown the list of import-able files, click the Import files button
  • How do I delete patterns palettes and layouts?
    1. Click the Browse button on BeadTool's toolbar
    2. Navigate to the item in your Library that you want to delete
    3. On Windows, right-click on the item and select Delete
    4. On Mac OS X, hold your Control key down while clicking with your mouse and select Delete
  • How do I sort the items in my Library alphabetically?

    You can sort your BeadTool Library files and folders alphabetically by:

    1. Run BeadTool and click View->Options (BeadTool4->Preferences on Mac).
    2. Select the Library tab.
    3. Change the Sort items by option to Alphabetically
  • Where is the BeadTool Library located on my computer?
    About the BeadTool Library

    BeadTool's Library is a single-file database that stores all of your patterns, palettes, stamps and layouts.

    In most cases, I do not recommend accessing the Library database file directly because of the potential for breaking things. However, there are some cases that you have no choice (like restoring from the hard drive of a dead computer).

    Where is it located?

    The location of the database file depends on what operating system you're using. Furthermore, one of the parent folders on the path is likely to be hidden (because you're not supposed to be accessing this part of your computer anyway).

    Replace YourUsername with whatever your username on that computer you installed BeadTool onto.

    Windows XP

    C:\Documents and Settings\YourUsername\Application Data\BeadTool\BeadTool.db

    Windows Vista/7/8

    C:\Users\YourUsername\AppData\Roaming\BeadTool\BeadTool.db

    Mac OS X

    /Users/YourUsername/Library/Application Support/BeadTool/BeadTool.db

  • How do I transfer a single pattern to another computer?

    You can transfer a single pattern or an entire folder of patterns from one computer to another. These instructions can be applied to patterns, stamps, palettes and layouts.

    On computer 1:

    1. Click the Browse button on the main toolbar
    2. Navigate to the pattern you'd like to transfer
    3. Right-click on the file and select the Save to option
    4. Save the file to an easily accessible place (like your Desktop)
    5. Transfer that file to the target computer.

    On computer 2:

    1. Click File->Import->Single file.
    2. Select the file and click the Import button.
    3. Your file will be imported into your BeadTool Library under the My Patterns folder.
  • How do I rename a pattern, palette or layout?
    You can modify the meta-information of any BeadTool Library object by right-clicking on it and selecting the Properties menu item.
    1. Run BeadTool and click the Browse button
    2. Navigate to the item you want to modify
    3. Right-click on the item and select the Properties menu item.
    4. You can now rename, change the description and author information