Help Center

A collection of frequently asked questions
Designing
  • How do I add text and letters to my pattern?

    Adding Text to Your Pattern

    To add letters and text to your pattern, follow these steps:

    1. Click Pattern->Add text from the main menu.
    2. Type the text you want to add into the Text field.
    3. Optionally choose a font and size.
    4. Click the Add button.
    5. The text is now in the clipboard. Drag the text to where you want it in your pattern.
    6. Click Edit->Paste from the main menu.
    7. Click anywhere outside the selection to discard the contents of the clipboard.

    There is also an instructional video that shows you how to do it here.

  • How do I replace all beads of a certain color in my pattern?

    There are a couple of ways to do this.

    The easiest is to drag a bead from your Palette, Quick Palette or Bead List onto the bead you want to replace in your pattern. Doing this will replace all occurrences of that bead in your pattern with the one you dropped onto it.

    There is also a video that demonstrates how to do this on the Learn page of the website.

  • Why doesn't copy and paste work?

    Copy and paste works slightly different than some other graphics applications you may be used to.

    With BeadTool, if you don't see the copied selection, it doesn't exist. For example:

    Other graphics programs

    1. Select the area you want to copy
    2. Copy
    3. Paste
    4. Move to desired location

    BeadTool copy and paste

    1. Select the area you want to copy
    2. Copy
    3. Move to the desired location
    4. Paste

    There is a video that will demonstrate how to copy and paste here.

  • How do I enlarge the pattern?

    The answer to that question depends on what you're doing. Do you want to enlarge what's printed or enlarge what you see on your screen? I have an answer for both!

    Enlarging the printout

    BeadTool uses a templating system called Layouts for printing. Templates can be created and customized in many ways. BeadTool has some built-in Layouts for you to use, too. To learn more about layouts, please watch this video.

    Enlarging the beads on your screen

    There are a couple of ways to do this depending on what your needs are. The obvious way is to click on the Zoom button on the toolbar.

    Another way is to edit the actual pixel width/height of each bead in your Options. To do that just:

    1. Click View->Options from the application's main menu (BeadTool4->Preferences on Mac OS X)
    2. Select the Pattern tab
    3. Change the Bead width and Bead height options to whatever you like
  • How do I insert rows or columns into the middle of my pattern?

    It's easy to insert and remove entire rows or columns from anywhere in your pattern.

    There's an instructional video that will show you how to do it here.

  • How do I save my pattern as an image file?

    Exporting patterns as images

    1. In BeadTool, click File->Export->Pattern from the main menu
    2. Adjust the patterns properties until you get the desired image
    3. Click the Export button
    4. In the Save dialog, choose the name and type of file you want to save it to
    5. Save it to an easily accessible place (your Desktop, etc)
    6. Attach the file in an email

    Hint: PNG format gives the best quality image and JPG gives the smallest file size.

  • What stitch types does BeadTool support?

    BeadTool 4 supports the following stitches:

    • Loom
    • Square
    • Brick
    • Peyote (1-9 Drop)
    • Tubular Peyote
    • Native American Gourd
    • Right Angle Weave (1, 2 & 3 bead)

    Word charts are generated for all stitches except Right Angle Weave

  • Why can't I import pictures?

    Most likely you're asking this question because you're clicking File->Import->Single file. The File->Import functions are for importing native BeadTool files into your Library such as bead patterns, palettes and layouts.

    To load a picture for transferring, click the "Picture" button on the main toolbar or click Picture->Open on the main menu.

  • How do I increase the size of the bead grid?

    If the size of the beads are too small on your screen and it's making things difficult to design, there's a couple ways to increase the size of them.

    Zoom

    1. Click the Zoom button.

    Change the base size

    If that's not good enough, you can change the base size for all beads

    1. Run BeadTool and click View->Options (BeadTool4->Preferences on Mac)
    2. Select the Pattern tab
    3. Change the Bead width and Bead height options to whatever you like.
  • Can I transfer a PDF into a BeadTool pattern?

    It is not possible to convert a PDF that contains a pattern into a viable pattern through BeadTool's transfer functions. No software can create a copy of a copy with any amount of accuracy.

    If you have a PDF of a pattern that you would like to copy, you would be better off contacting the author of that pattern and asking for a revision.

    If you are the author of that PDF and want to get it into BeadTool, your best bet would be to extract the image from the PDF, load that image into BeadTool and hand-trace it.

  • In your videos you mention right clicking but how do I right click on a Mac?

    Right-click

    You can perform contextual clicks on your Mac by clicking your mouse button while holding down the Control key on your keyboard.

    Note: Apple likes to do their own thing so they don't include standard mice with their computers. However, you can use any 3-button mouse on a Mac.

  • How do I add my own information to my pattern files?

    BeadTool stores user-specific metadata inside every pattern, palette and layout you save. By default, this information is the same as your registration name and email.

    However, you can change the information that gets saved by

    1. Run BeadTool and click View->Options (BeadTool4->Preferences for Mac)
    2. Select the Author tab
    3. Change the information to whatever you want
    4. Click the Save button

    Now every time you save a pattern, palette or layout, that new information will be saved with the file.

    Note: You will need to go back and re-save each file that you want the new information to be included in.

  • Can I physically rotate the pattern so that it lays horizontally?

    Changing Orientation

    It's not possible to change the orientation of the pattern in BeadTool 4. A future version will have this feature.

  • How do I remove the blank beads from a shaped pattern?

    A shaped pattern in BeadTool is called Freeform. Although cells in a pattern will always exist, you can hide them.

    Before you enable Freeform

    If you have extra space on any side of your pattern, it's a good idea to trim it before enabling the Freeform option.

    1. Click Pattern->Trim from the main menu

    Enabling Freeform

    1. Click Pattern->Freeform to toggle showing the blank beads in your pattern.
    2. Click the same menu item again to show the empty cells again
  • How do I save something as a Stamp?

    About Stamps

    Stamps let you save smaller parts of one pattern so that you may reuse them in different ones. There's a video about stamps here.

    If you've watched the video already and still find that you can't save any stamps, it's because you're clicking the Save menu item under the File menu instead of the Save button under the Edit menu.

  • How do I save my pattern's beads as a palette?

    You can save your pattern's current list of beads as a custom palette very easily. This comes in handy when you want to create a new pattern with that same limited set of bead colors.

    1. Run BeadTool and load your favorite pattern
    2. Click File->Export->Bead List
    3. Enter a name for your new palette and click Save

    Now you can change the current palette to the one you just saved and start designing.

  • How do I set BeadTool to display millimeters, centimeters or inches?

    Changing Measurement Units

    1. Run BeadTool
    2. On Windows, click View->Options
    3. On Mac, click BeadTool4->Preferences
    4. Select the Pattern tab
    5. Change the Measurement units option to whatever you like
  • Can I sell the patterns that I create with BeadTool?

    Copyright Law

    United States copyright laws are very clear on this: As soon as you create a work, it is considered copyrighted and nobody can tell you what you're allowed to do with it.

    In other words you have the legal right to sell anything you create no matter what software you used to create it with.

    Examples of legitimate works

    These types of work are protected under US copyright law

    • A photo you take
    • A drawing you sketch
    • A pattern you design

    However, derivative works are a different story and you should think carefully before selling something you did not create entirely on your own.

    Examples of copyright infringement

    Unless the author of a prior work gives you permission to copy, it's considered copyright infringement:

    • Duplicating a pattern you purchased
    • Transferring a photo you didn't take yourself
    • Using an unlicensed logo or trademark
  • Where is the center of my pattern?

    By default, BeadTool does not show the center markers in your pattern but you can change your settings to show them.

    1. Run BeadTool and click View->Options (BeadTool4->Preferences on Mac)
    2. Select the Pattern tab
    3. Under the Appearance heading, enable the Draw markers option
    4. Enable the Draw center markers option
    5. You can also display markers every N columns or rows by changing the respective options
  • Why can't I modify the column and row count anymore?

    The reason the column and row modifier controls are disabled (greyed out) is because you've put the pattern into Freeform mode. While the pattern is in Freeform mode, you will not be able to modify the columns or rows.

    To modify the columns or rows, just uncheck Pattern->Freeform in BeadTool's main menu.

  • How do I change the size of the beads in an existing pattern?

    If you would like to change the palette that your pattern uses, you can use the Transpose feature.

    This action cannot be undone!

    1. Run BeadTool and load your pattern
    2. Click Pattern->Transpose on the main menu.
    3. Choose the new palette you want your pattern to use
    4. Choose the match criteria
    5. Click the Transpose button
  • My photo transfers are not coming out very well. What can I do?

    There are a few variables that determine the outcome of a photo transfer. The main one is the photo you're using. Some photos will transfer with no problems and others won't transfer well at all no matter what you do.

    Here are a few pointers to help with transferring those tough photos:

    Filter Your Palette

    BeadTool lets you choose what types of beads you're willing to work with. When transferring those tough photos it can be helpful to eliminate certain kinds of beads.

    1. Run BeadTool and load your photo
    2. Prepare and position the photo as desired
    3. Click the Transfer button on the toolbar
    4. Select the Filters tab in the Transfer dialog

    In the Show these types section, uncheck the following:

    • Transparent
    • Copper Lined
    • Silver Lined
    • Gold Lined

    In the Show these finishes section, uncheck the following:

    • Luster
    • Metallic
    • Metallic AB

    Adjust Your Photo

    Sometimes it helps if you lighten or darken your photo before starting your transfer.

    1. Set up your patterns size, stitch and choose a palette
    2. Load the photo you want to use and move/stretch/shrink it as needed
    3. Click Picture->Adjust Colors from the main menu
    4. Increase or decrease the brightness and/or saturation as needed
    5. Transfer your photo by clicking the Transfer button on the toolbar

    Transfer Settings

    Experiment with different transfer settings. If you are new to transferring, check the video here.

    • Usually 32 colors is more than enough to get a good transfer
    • Be sure you are working with a full stock palette instead of a custom one.
    • Switch the transfer Method to Popularity if Nearest Color isn't producing good results.
    • Sampling can play a small role in transfers. Experiment with lower values.

    When All Else Fails

    If you're still not getting good transfers after playing with the above settings, you may need to re-take the photo or edit the photo in a professional photo editor.

  • Why is the size of my pattern incorrect?

    I could write a book on the subject! Here are the most common reasons your pattern ends up a different size than what BeadTool calculates

    Bead sizes are not as uniform as you think

    No matter what the bead manufacturer boasts, no bead is uniform. Every-single bead I have ever measured with a digital caliper is a different size than the one before it. Each size difference adds up so the larger your pattern, the larger the inconsistency between BeadTool and the stitched pattern.

    You changed bead sizes

    BeadTool calculates the size of your pattern based on the first bead you add to your pattern. So if you accidentally add a Size 10/0 bead onto your new pattern and then design the rest of your pattern using 11/0 beads, BeadTool will still calculate the size based on that first 10/0 bead you added. The only way to get BeadTool to recalculate the pattern size is to click the New button or click Pattern->Transpose.

    Rows are not columns and columns are not rows

    Seed beads are always taller than they are wide. So when you set the dimensions of your pattern, you must take care to set the rows according to the vertical pattern size (height) and the columns to the horizontal pattern size (width). Switching them will give you inaccurate pattern measurements.

  • How do I remove the picture from my Work Area?

    You can't delete or remove the the picture but you can hide it. Just click the big Picture icon on the toolbar to toggle the picture's visibility.

  • How do I change the measurements of the beads?

    Changing the size of beads and patterns

    I have gone to great lengths to ensure that the sizes of the beads are correct. However, if you disagree with them, there is a solution. While you can't alter Stock palettes directly, you can make a copy of the palette and alter those measurements.

    1. Run BeadTool and click the Browse button
    2. Navigate to the Stock palette you wish to alter
    3. Drag the Stock palette to your Custom folder
    4. Navigate to the copy you just made in your Custom folder
    5. Right-click (Control Click on Mac) on that copied palette and select Properties
    6. Rename the palette to something distinct from the palette you copied to avoid confusion
    7. Click the Advanced tab and change the measurements
    8. Click OK

    Now that new copy of the palette will be available in the BeadTool Palettes list. However, it will not change the measurements of the old patterns that used the Stock palette. You will need to use the Transpose function to alter existing patterns.

    Transposing

    You can change the palette associated with any pattern by clicking Pattern->Transpose from the main menu. This will not always exchange each bead 1:1 .

    1. Run BeadTool and load the palette you want to transpose
    2. Click Pattern->Transpose
    3. Select your new palette in the Target Palette setting
    4. Select "Color, Type and Finish" in the Must match setting
    5. Click the Transpose button
  • How do I completely remove a bead from my pattern?

    You can remove all occurrences of any bead in your pattern by

    1. Right-click on the bead in your Bead List
    2. Select the Erase option
  • How do I distinguish similar beads in my pattern?

    Distinguishing Similar Colors

    Sometimes it can be difficult to differentiate similar colors in your pattern. To help with this, you can highlight any bead you want. There are two ways to do this:

    Pick a bead from your Bead List

    1. Right-click on any bead in your Bead List
    2. Selecting the Find option will highlight every occurrence of that bead in your pattern
    3. Select Un-find to remove the highlights

    Pick a bead from your Pattern

    1. Right-click on any bead in your Pattern. This will select that bead in your Bead List.
    2. Right-click on that bead in your Bead List and select the Find option and all occurrences of that bead will be highlighted in your Pattern
  • Why doesnt my vendor have the bead numbers you specify?

    That's something you should be asking your vendor. I have no control over what vendors choose to stock.

  • How do I start a new pattern?

    Click that big New button on the toolbar or click File->New from the main menu.